Uusi kone tai vanha henkiin… – osa 4

Sain sitten hankittua Huuto.netistä sen uusvanhan näytönohjaimen: Matrox P650. 2xDVI, ei tuuletinta, ei kummoinen 3D, mutta laadukas 2D. Torstaina sen ehdin illalla asentaa ja todeta toimivaksi. Perjantaina ääni kuitenkin ikävä kyllä muuttui kellossa (kuten kolmesta edellisestä T5vs-viestistä kenties voi päätellä…).

Lisäsin torstaina illalla (yöllä) koneeseen vielä sen kolmannen gigaisen muistikamman ja testasin, että toimiihan tuo. Aamulla kursorin ympärille ilmaantui kuitenkin ikäviä häiriöitä. Kokeilin poistaa muistin, kun arvelin vian olevan siinä, mutta ei, joten palautin sen paikalleen. Vekslasin sitten korttia pari kertaa, poistin ja asensin ajurit uudelleen, kokeilin vanhalla ohjaimella, että homma toimii jne. Taisi olla sitten lauantaina, kun pääsin siihen asti, että putsasin kontaktit moneen kertaan ja kokeilin kaiken mahdollisen. Jossain vaiheessa huomasin, että tietyissä asennoissa homma toimii, mutta se on pienestä kiinni.

Sunnuntaina kokeilin välillä vanhalla näytönohjaimella ja huomasin, että pari isompaa graffiikkahäröä tuli silläkin. Olin olettanut, että Matrox olisi vain saanut lisävaurioita, mutta nyt pelästyin AGP-slotinkin kärsineen jotenkin. Onneksi hoksasin sitten, että kursori liikkui ja näkyi normaalisti ongelma-alueillakin eli rikki olikin vain taustakuva eikä mitään muuta uutta. Jos olisin heti hoksannut sen, olisin säästynyt parilta rebuutilta.

Ylimääräiset rebuutit vioittivatkin sitten jotakin Windosissa, joten jouduin turvautumaan asennuksen korjaukseen (Checkdisk korjasi c:\Windows\system32\config\in, joka oli hajonnut) ja sen jälkeen vielä Järjestelmän palautukseen. Sekään ei vielä eilen illalla auttanut, vaan käynnistys menee aina jossain vaiheessa jumiin (jokin ohjelma varmaan ottanut osumaa), joten tänään pitää kokeilla lisää. Myös yhden muistigigan poistamista pitää kokeilla, jos vaikka se ohjelma, joka jumittaa startin, ei pidäkään kolmesta gigasta. Näytönohjaimen ajurit eivät siitä kyllä tunnu hermostuvan. Katsotaan, mitä ilta tuo tullessaan. Uudelleenasennukseen en mielelläni ryhtyisi, mutta toki teen senkin, jos muu ei auta. Jos sitten vaikka saisin viimein taas T5vs-projektin taas rullaamaan…

Uusi kone tai vanha henkiin… – osa 2

Eilen kertoilin konetilanteestani ja nyt voi ilokseni todeta, että ainakin osa toimenpiteistä vaikuttaisi tehonneen. En ehtinyt vielä kokeilla kaikkea, mutta käynnistys tuntuisi nyt onnistuvan kerralla (ilman vaihtelevaa määrä BSOD-kierroksia).

Suorittamani toimenpiteet olivat:

  1. kaikki USB-laitteet USB2.0-portteihin
  2. USB-ajureiden poistaminen ja uudelleen tunnistaminen laitehallinnassa
  3. uusimman ATI Catalystin asentaminen
  4. BIOS-asetusten tarkistus
  5. Catalystin asetusten säätäminen

Vaiheen 1 ja 2  jälkeen mikään ei vielä muuttunut. Vaiheessa 4 tarkistin kaikki asetukset, mutta oleellisista vga fast-write oli jo disabled, vaihdoin kuitenkin AGP-näytönohjaimen oletukseksi ja lisäksi disabloin quick bootin (ts. kone kelaa muistin läpi ennen kuin aloittaa muut toimet – kahdella gigalla se vie hetken aikaa). Vaiheet 3 ja 4 toivat kuitenkin mukanaan kaksi muutosta: ei BSODia buutissa eikä kolmas näyttö enää suostunut toimimaan (PCI-väylään kytketty ikivanha ATI Rage II -näytönohjain, joka ei ilmeisesti käynnisty ollenkaan, jos AGP on oletuksena). Vaiheen 5 jälkeen koetin vielä muuttaa pari BIOS-asetusta ennen kuin buuttasin Windowsiin asti. Plug’n’Play Aware OS -asetuksen enabloiminen ei kuitenkaan vaikuttanut kolmanteen näyttöön mitään. Catalystin asetuksissa disabloin agp writen molempien näyttöjen osalta.

 Kaiken tämän jälkeen päätin sitten vielä kokeilla olisiko USB:lle tapahtunut jotain – ja olihan sille! Kokeilin ensin tikulla, josta XP ei herjannut, notta se voisi toimia nopeammin USB2.0-portissa. Tästä yllättyneenä kokeilin vielä siirtää kuvia suoraan pokkarikamerastani ja ne siirtyivätkin rivakasti. Näyttäisi siis siltä, että kaksi ongelmaa tuli ratkaistuksi yhden illan aikana, vaikka aikaa ei ollut edes käytettävissä kovin paljon.

Tänään varmaankin irrotan PCI-näytönohjaimen koneesta kokonaan ja siirryn toistaiseksi ”vain” kahden näytön käyttöön. Lisäksi, jos em. korjaukset tuntuvat edelleen olevan kohdallaan, kokeilen varmaan jälleen, jos kolmas giga muistia kelpaisi systeemille. Catalystin kaatuminenhan se ongelma aiemmin oli eli uusimman version ja asetusmuutosten jälkeen toivoa voisi olla. Quick bootin enablointiakin varmaan kokeilen jossain välissä nähdäkseni oliko sillä osansa BSODin katoamisessa vai ei. Kolmen gigan kanssa olisi kuitenkin kivempaa, jos sen läpikäyntiä ei startissa tarvitsisi odotella, mutta toki se on BSODia parempi, jos valita pitää. Jos vielä äänikortin särinäkin kaikkoaisi, niin vanha kone saisi varmasti lisäaikaa vielä melkoisesti. Uuden kyllä ehtii hankkia myöhemminkin, jos vanha vain toimii kunnolla.

Tiivistettynä tilanne eilen illalla: kone käynnistyy kerralla ilman BSODia ja USB2.0 toimii, mutta kolmas näyttö ei. Muiden ongelmien osalta testaus on vielä kesken.

Uusi kone tai vanha henkiin…

Jo useita vuosia olen toistuvasti miettinyt uuden koneen hankkimista. Koneenihan on ollut jonkin verran rikki jo kolmesta viiteen vuotta. Viime vuoden alkupuolelta lähtien vikoja on alkanut olla kertyneenä sen verran paljon, että koneen vaihtaminen oli tarkoitus hoitaa jo viimeistään tänä keväänä. Koska kuitenkin törsäsin uuteen kameraan, lykkäsin koneen päivittämisen (alku)syksyyn.

Eilen kuitenkin keskustelin erään kaverini kanssa koneista ja innostuin tutkailemaan Huuto.netistä, jos joku vaikka kauppaisi samanlaista emolevyä kuin omani (MSI KT3 Ultra-ARU eli MS-6380E, VIA Apollo 266A -piirisarja, AMD Socket A, ATA133 RAID, USB 2.0 [NEC], 6.1 SPDIF koksi ja optinen lähtö). Ihan samaa ei löytynyt, mutta päädyin edelleen FAQ:n kautta käyttäjäfoorumiin, jossa törmäsin kuvauksiin samoista ongelmista, joita minullakin on ollut.

Ensimmäisenä ilmennyt ongelmani on USB2.0:n toimiminen vain USB1.1:n nopeudella (vain yksi esimerkkiketju, sama ongelma tuntuu olevan melko yleinen). Joitakin ratkaisujakin tarjotaan ja aionkin kokeilla niitä. Lainaanpa tähän pari ratkaisuehdotusta:

I solved my problem
When i use my usb 2.0 ports i must have nohting in the usb 1.1 ports
I now put all my usb devices in the usb 2.0 ports
This comes because my chipset has a major bug

Toinen vaihtehto: Poista kaikki USB:hen liittyvät ajurit, boottaa ja anna Windowsin tunnistaa ne uudelleen. Toista, kunnes USB2.0 toimii…

Seuraava ongelma tuli ATI Radeon 9600XT:n kanssa lisämuistien myötä (osat 2 ja 3). Catalyst-ajurit nimittäin kaatuvat, jos muistia on enemmän kuin 2 gigaa. Syy voi tietysti olla esim. muistiavaruuden loppuminen kesken, jos näytönohjaimen 512Mt:n varaus lasketaan yhteen kolmen gigan keskusmuistin kanssa, mutta näin ei mielestäni pitäisi olla. Myös tähän tarjotaan foorumilla joitakin ratkaisuja (lähinnä ajuripeliä) ja niitäkin aion kokeilla. Voi olla, että näytönohjaimella on jotain tekemistä myös koneen buuttausongelman kanssa, joka kyllä on ilmennyt toisinaan jo pitkään ja muistaakseni myös ennen tätä näytönohjainta. Kone siis käynnistyy Windowsin aloitteluun asti, mutta sitten tule BSOD. Ja toisinaan kone myös jumiutuu kesken kaiken ja se on pakko sammuttaa väkisin. USB2.0-ongelman jälkeen tämä on ikävin. Ehkä jopa ikävämpi, sillä USB2.0:aa vaativat massasiirrot esim. kamerasta voin hoitaa läppärillä ja synkata verkkolevyn kautta. Silloin varmuuskopiotkin tulee tehtyä samalla. (Focus on Positive!) Lopuksi vielä eräs ratkaisuehdotus näihin Radeon 9600 ongelmiin:

For those of you having trouble getting your radeon 9600 pro video card working well (lock-ups, serious errors, mouse pointer problems, corrupted craphics), and especially lock-ups with certain games (ie. c&c generals) try the following:

My kt333 based msi kt3 ultra-aru mobo (and maybe others) can now be run at full hardware acceleration and 100% stable perfromance by:
1) download and install latest via chipset driver from via site.
2) download and install latest (soundblaster live!) sound card driver
3) download and install latest catalyst 3.7 driver/control panel/samartgart from ati.
4) disable vga fast-write in bios..
5) go to c:programsati technologyati_control_panel and execute smartgart link
6) enable – pci read/write and agp read.
7) disable – agp write (default in my case was ”on” causing the problem).
8) ”apply”, reboot, then ”ok”.

If you are feeling lucky, just try steps 3 through 8…..

Kolmas ongelma ilmaantui jossain vaiheessa ja on tavallaan vain pikkuseikka, mutta pahimmillaan melkoisen häiritsevä. Äänet nimittäin särisevät ja särkyvät varsinkin leffoja katsellessa. Ongelma ei ole liitännässä, koska sama ilmiö on myös optisessa lähdössä. Syyttäisin siis joko äänikorttia tai ajureita. Tätäkin koetan varmaan ratkoa ajuripäivityksillä tai uusimpien ajurien asentamisella uudelleen.

Jos saisin USB2.0-ongelman ratkaistua, olisi konetta huomattavasti mukavampi käyttää. Jos käynnistymis- ja kaatumisongelmat ratkeaisivat, saisi kone varmsti lisäaikaa ja ääniongelman poistuminen parantaisi fiilistä entisestään. Jos sitten saisin vielä näytönohjaimen hyväksymään kolmannen gigan muistia kenkkuilematta, olisi kone taas melkein kuin uusi. Uuden koneen hankkiminen on toki kivaa, mutta budjetin lisäksi jarruttaisin sitä edelleen mielelläni siksi, että nykyisen koneen käyttiksen ja softat olen viritellyt niin mittojen mukaan, että uudella koneella pääsisin samaan vasta kuukausien (tai vuosien) kuluttua. Enkä saisi kaikkea (etenkään meta)dataakaan siirrettyä tai synkattua uudelle koneelle sellaisenaan. Ainakin kuva-arkiston osalta menettäisin jonkin verran oheisinformaatiota. Jos voisin vain vaihtaa emolevyn ja pitää kaiken muuten ennallaan, en jarruttelisi, mutta yhteensopivuus emojen välillä ei ikävä kyllä ole niin hyvällä tasolla (imageyhteensopivuus…).

Muistiongelmia ja MS Visual C++ Runtime Library: Runtime Error, osa 2

Tuhrasin sekä eilen että tänään rutkasti aikaa keskiviikkona ilmenneen ja eilen pohdiskelemani Runtime Errorin debuggaamiseen. Etsin ratkaisuja verkosta ja mietin, mikä niistä voisi toimia ja mikä ei – lähinnä sen perusteella, mitä ohjelmia olin juuri asentanut ja mitkä olivat olleet käytössä jo pitempään ja toisaalta mitä minulla ei ollenkaan ole. Syypääksi osoittautui lopulta käyttämäni imurointiapuohjelma Free Download Manager (FDM). Sen poistaminen korjasi ongelman heti eikä uudelleen asentaminen aiheuttanut niitä uudelleen. Ilmeisesti muistisekoilu ja näytönohjaimen ajurien kanssa puljaaminen sekä muu virittely (mm. selaimen) oli onnistunut jotenkin sotkemaan FDM:n dll:t tjsp., mistä seurasi sitten ongelmia. Nyt kaikki kuitenkin tuntuu olevan tältä osin kunnossa, joten huomenissa menen vielä neuvottelemaan, jos saisin kolmannen muistin vaihdettua saman merkkiseen kuin kaksi muuta. Sitten varmaan kokonaisuus on tasapainossa.

Niin, en muuten tosiaan keksinut syyllistä itse, vaan mainitsemani nettihaut tuottivat tulosta. Tiivistetyimpänä oikea ratkaisu löytyy toisesta vastauksesta, joka on annettu MSDN Forumsin ketjuun.
Kysymys kuuluu:

I am facing problem as follows in my PC having windows xp pro as OS.
When I am clicking C drive icon folders are opened. When I next click any folder I get the message as Run Time error C:\windows\explorer.exe abnormal program termination–microsoft visual C++ runtime Library. Kindly arrange to help me to solve this problem.

Ja vastaus:

OK I had the same problem and for the people that might have this problem in the future to make it easier becouse I had to look for an answer for this in the tiniest lines on every forum and I found the solition. So what might help you is one of this or all of them try them all until it works:

1. Uninstall Google Toolbar
2. Uninstall IE 6.0 and reinstall, unistall IE 6.0 and install IE 7.0
3. Scan with Ad-aware, spybot Search & Destroy in SAFE mode
4. Downloaded BHO Captor, ran the program(usually helps all the time)
5. Disable McAfee spam killer
6. Unistall McAfee Security Centre
7. Unistall FREE DOWNLOAD MANAGER(helped me to fix the problem and many others)

Kohta 7. siis ratkaisi ongelman minun kohdallani, kuten useat muutkin ovat sekä tässä ketjussa että muualla kommentoineet. Myös muut kohdat ovat osoittautuneet ratkaisuiksi toisilla, mutta tämä siis minulla. Viimeisimmän kerran löysin tämän ratkaisun luokse MS:n Live Searchin kautta haulla Microsoft Visual C++ Runtime Library error explorer.exe abnormal program termination, vaikka lähdinkin liikkeelle Yahoo!:n ja Googlen kautta. Niistä löytämäni viestiketjut ohjasivat Microsoftin sivuille, joiden kautta sitten päädyin hakemaan Knowlegde Basesta ja Live Searchilla ja päädyin lopulta viittaamalleni sivulle.

Kun nyt kokeilin tätä täsmälleen samaa halua Google löysi huomattavasti epäselvempiä vaihtoehtoja, mutta Yahoo! löysi ensimmäiseksi juuri tämän viittaamani MSDN Forumsin ketjun. Useimmiten käytän hauissani Googlea, mutta tässä tapauksessa osoittautui jälleen kerran, että jos ratkaisua ei löydy heti, kannattaa hakutermien parantelun lisäksi koettaa muita hakukoneita. Juuri tätä varten lisäsin selaimeeni (Firefox) CustomizeGooglelaajennuksen, joka tarjoaa hakutulosten alkuun linkit ”Kokeile hakuasi muilla hakukoneilla: Yahoo, Ask, AllTheWeb, MSN, Lycos, Technorati, Feedster, Bloglines, Altavista”. Näistä Yahooo!:n lisäksi AllTheWeb ja Altavista palauttavat tuon mielestäni hyödyllisimmän tuloksen ensimmäisten joukossa. Muissa tulos on huonompi – etenkin blogeihin keskittyvissä hauissa, jotka eivät palauta mitään hyödyllistä.

Muistiongelmia ja MS Visual C++ Runtime Library: Runtime Error

Ostin viime kuun lopulla gigan lisää muistia koneeseeni. Tarkoitus oli kasvattaa muistin määrä 2,5 gigaan. Muistin kuitenkin väärin sen, millaisia kampoja koneessani entuudestaan oli – 1024+512 sijasta 3×512. Päälle päätteeksi tuurini oli vielä sen verran huono, että vanhat CL2,5 -luokitellut muistit aiheuttivat lieviä vakausongelmia uuden CL3-laatuisen muistin kanssa. Päädyin siis väliaikaisesti itse asiassa vähentämään muistia eli jätin koneeseen vain yhden 1024 Mt RAM-moduulin. Tähän en kuitenkaan ollut aikeissa tyytyä kovin pitkään.

Eilen sitten kävin hakemassa kaksi kappaletta gigaisia muisteja, jotka kuitenkin olivat eri valmistajan kuin ensimmäinen. Spekseiltään kyllä identtiset, joten niiden piti toimiman oikein yhdessä aiemman muistin kanssa. Kotona sitten laitoin muistit koneeseen ja starttasin. Muuten näytti hyvältä, mutta kun ei näyttänyt – resoluutio oli tipahtanut 800×600-tilaan eli oletin näytönohjaimen ajurien jotenkin seonneen. Aloinkin sitten tyhmänä tutkia tilannetta tällä oletuksella ja tuhrasin jonkin aikaa, kunnes hoksasin, että kannattaisi eliminoida syiden joukosta muistit.

Sieltähän se syy sitten löytyikin. Pelkällä vanhalla gigaisella muistilla kone starttaisi vallan nätisti ihan oikealla resoluutiolla. Samaten pelkillä uusilla muisteilla kaikkia näytti toimivan vallan mainiosti. Yhdistelmä sotki sitten taas näytönohjaimen pasmat pahemman kerran, mistä onneksi pääsi takaisin ihan vain ottamalla erimerkkisen palikan pois. Jätin siis kaksi uutta gigaista muistia koneeseen toistaiseksi ja tutkin pohdin seuraavaa askelta vielä erikseen.

Asensin tämän sekoilun jälkeen yhden lisäohjelman, jonka asentamisen jälkeen huomasin muutamia ikäviä oireita (lähinnä sen, että resurssienhallinta kaatuu MS Visual C++ Runtime Library: Run Time Erroriin(1, kun yritän mennä jollekin muulle kuin järjestelmän sisältävälle asemalle). Lienee mahdollista, että ne johtuvat kyseisestä ohjelmasta (Yahoo! Desktop Search – X1, tarkemmin varmaankin kyseisen ohjelman ensimmäisestä indeksointikierroksesta, jos se aiheuttaa kenties tarpeettoman ahkeraa levyn käyttöä tai lukitsee jotain väärin tjsp.), mutta jossain vaiheessa aloin miettiä, että jos ne johtuvatkin muisteista, enkä vain huomannut niitä ennen X1:n asentamista. Tätä aion testata, kunhan kerkiän. Tai on mahdollista, että systeri on ehtinyt testata asiaa puolestani, kun ilmeisesti on katsellut kämpässäni leffoja minun puurtaessani virtuaalisen ”sorvin” ääressä. Siitä kuulen sitten tarvittaessa illemmalla. Toivottavasti tietysti kone ei ole kaatuillut kovin monta kertaa. (Viimeksi niin kävi tuon ensimmäisen muistien yhteensopimattomuuden takia kaksi kertaa yhden elokuvan aikana.)

Kaikean kaikkiaan – vaikka muistien hinnat ovatkin laskeneet melkoisen siedettävälle tasolle – kustannuksia kertyi sen verran, että aion palata liikkeeseen (Mikromaja) keskustelemaan, jos saisin vaihdettua joko ensimmäisenä ostamani muistin tai jälkimmäisenä ostamani muistit saman merkkisiin. Lisäksi kannattanee tietysti kysyä, jos heillä on tietoa mahdollisista yhteensopivuusongelmista esim. Sapphiren ATI Radeon 9600 XT:n (tuulettimeton ja siksi hiljainen) GPU:n tai kenties emolevyni (MSI KT3 Ultra-ARU + AMD Athlon XP 2600+ CPU) ja ostamieni muistien (400MHz DDR CL3 1024Mt, ensimmäinen M-Tec aka TwinMOS, jälkimmäiset Buffalo) kesken. Näytönohjainhan (ajurit) muisteista näytti sekoavan, mikä tietysti saattaa olla näennäistä, mutta sekin mahdollisuus täytyy pitää mielessä, kunnes toisin todistetaan. Ei kannata tuomita muisteja ennen aikojaan.

1)Tarkemmin lainattuna virheilmoituksia esiintyi kahta lajia:
Microsoft Visual C++ Runtime Library
Runtime error!
C:\windows\explorer.exe
abnormal program termination

ja
Microsoft Visual C++ Runtime Library
Runtime Error!
Program C:\Windows\explorer.exe
This application has requested the Runtime
to terminate it in an unusual way.
Please contact the applications support
team for more information.

Jos ei ensimmäisen, niin ainakin toisen kerran jälkeen explorerin kaatuminen sitten kaatoi myös Active Desktopin. (Mitäs otin sen käyttöön saadakseni eri taustakuvat kahdelle näytölleni…)

Powered by ScribeFire.