Kone yskii…

Viime aikoina olen julkaissut turhan usein kuvia useita päiviä myöhemmin kuin on tarkoitukseni. Tällä kertaa syynä on se, että koneeni päätti yskähdellä ja kahtena edellisenä päivänä Picasa, jota käytän kuva-arkistoni hallintaan, päätti hukata koko kirjastoni ja lukea sen alusta uudelleen. Tämä harmitti minua sen verran, etten viitsinyt nähdä sitä ylimääräistä vaivaa, minkä kuvien julkaiseminen Picasaa hyödyntämättä olisi vaatinut.

Maanantain annoin Picasan latailla niin pitkään kuin sitä huvitti, mutta silti tiistaina kirjasto oli taas tyhjä. Päästin Picasan latailemaan pari-kolme tuntia, mutta sitten keskeytin sen toimet ja sammutin koneen yöksi. Tänä aamuna Picasa sitten yllättäen avasikin kirjaston taas ehjänä. Kahden edellisen päivän viiden vuoden takaiset kuvat ovat siis tiedossa jossain vaiheessa tänään. Tälle päivälle ei omaa kuvaa ole käytettävissä.

Blank!

Tässä parina edellisenä päivänä en ole päässyt sivujeni WordPresillä toimivaan osioon lainkaan. Selain tarjoaa vain tyhjää sivua. Samaa on ilmennyt aiemminkin. Aina jossain vaiheessa homma sitten taas toimii.

Vian ei pitäisi olla palvelimessa, koska muut osat sivuillani toimivat ja ne käyttävät yhtälailla niin PHP:tä kuin tietokantaakin siinä missä WordPress. Aiemmin ei ole ollut aikaa, mutta ehkä tänään ehdin kokeilla, jos WordPressin sekä mahdollisten lisäosien päivittäminen ajantasalle vaikuttaisi. Kunhan olen saanut sen tehtyä, on aika julkaista sekä eilinen että tämänpäiväinen T5vs-kuva.

Hitautta…

Jostain syystä sivuni tökkivät tänään. Tai oikeastaan vain WordPress tuntuu tökkivän, minkä arvelisin voivan johtua tietokannasta. Pari tuntia sitten pääsin vain valkoiselle sivulle, mutta tunti sitten sivut jo taas sentään toimivat. Esimerkiksi blogilista saa kuitenkin edelleen vain latausvirheen (ja sai sellaisen ainakin jo kuuden maissa illalla), joten kaikki ei edelleenkään ole kunnossa…

Kenties syypää on palveluntarjoajan suorittama siirto palvelimelta toiselle, vaikka sen kyllä piti tapahtua (ja varmaan tapahtuikin) jo keskiviikkona kestäen 24-32 tuntia. Ehkäpä jotain jälkivaikutuksia. Tai sitten vain jotain muuta tökkimistä. Toivotaan, että ongelma korjaantuu mahdollisimman pian kokonaan.

Kolmoskamera uusiksi

Kesäkuun lopulla (tarkemmin sanoen ?ntaina ?.6.2008) puolisen vuotta käytössä ollut ”kolmoskamerani” Ricoh Caplio R6 vaurioitui käyttökelvottomaksi. Vika ei todennäköisesti ole suuri, mutta se jumittaa objektiivin auki siten, että kamera ei kuitenkaan tajua sen olevan ulkona, vaan yrittää avata sitä lisää ja sitten sulkea. Koska objektiivi pääsee kuitenkin palaamaan vain puoliksi sisään, on kamera täysin jumissa. Kuvien katselukin onnistuu vain kikkailemalla/puoliväkisin.

Kamerat
Kamerat

Kävin eilen Verkkokauppa.comissa kyselemässä takuukuvioista. Siellä selvisi, että jos korjaus ei mene takuuseen (kuten pahoin pelkään), pelkkä käsittelymaksu on Verkkokaupan osalta 50€ ja huollon osalta muutaman kympin (tulkitsin, että kenties jotain 20-50). Näin ollen ei vaikuta taloudelliselta lähettää kameraa minnekään ostohinnan ollessa vajaa 250 tai nyt – hintojen pudottua puolessa vuodessa – enää vajaa 200 euroa. Päädyinkin siis tässä vaiheessa ostamaan uuden samanlaisen – koska kamera on palvellut hyvin ja pidän siitä – ja miettimään huoltokuvioita vielä erikseen. Ehkäpä koetan purkaa kameran ja katsoa, jos sen saisi itse kuntoon…

Kulutusyhteiskuntaa pa(r)h(a)immillaan: oli edullisempaa ostaa uusi laite, kuin edes selvittää voiko vanhan korjata. Luultavasti korjauksesta olisi tullut lisää joitakin kymppejä ellei peräti (lähes) uuden laitteen verran. Noh, tätä uutta yksilöä tulen käyttämään vain itse, jotta se ehtii ensimmäistä paremmin kuolettamaan hankintakustannuksensa. Kertyi ensimmäiselläkin toki runsaasti kuvia, joten ei tästä siinä mielessä pahasti takkiin tullut, mutta kolmisen vuotta on tähän asti ollut kompaktikameran tavoite-elinkaari minun käytössäni (ensimmäisellä Olympus Camedia C-750 Ultra Zoomilla se toteutui, Canon PowerShot S3 IS:llä ikää kertyi vain vuosi ennen Ricohin hankintaa sen rinnalle ja Canon EOS 450D dSLR liittyi joukkoon alle puoli vuotta R6:n jälkeen). Jatkettuna eli kevennetyssä käytössä sitten vielä lisää (C-750 on piilotellut laukussaan uuden kameran hankinnasta lähtien, mutta S3 toimii kakkoskamerana, jos 450D on liian raskas ja R6 puolestaan on jatkuvasti mukana kulkeva muistiinpano-, arkistointi- ja näppäilykamera).

Ohimennen katselin myös, millainen kamera voisi sopia äidin käyttöön. Ominaisuuksilla sen ei tarvitse koreilla, kokoa saa pikkuisen olla ja muodon olisi hyvä olla käteenistuvan perinteinen. Käyttövarma Point-and-Shoot siis. Yhden ehdokkaan bongasinkin, mutta pitää vielä katsella. Ja kysyä sitten tiestysti hänen omaakin näkemystään, kun kenties pari-kolme ehdokasta on tarjolla arvioitaviksi. Onneksi sillä ei ole kiirettä.

Omien kameroideni osalta yritän nyt vähän hillitä, mutta jos ykköstietokoneeni tokenee niin hyvin kuin tällä hetkellä näyttää, ei minun tarvitse rasittaa budjettia uudella koneella, vaan voin satsata optiikoihin ja kenties salamaan. Myös äidin kameraan voi löytyä ainakin osa summasta – iskänkin saisi ehkä osallistumaan hankintaa ainakin nimellisesti. Se vaatii kyllä valmistelua, mutta kun ei tosiaan ole kiire, niin mikäs on pohjustaessa. Ellen sitten säästä vaivaa maksamalla koko roskan itse. Ei siihen kuitenkaan pala kuin sata-kolme. Halvimmatkin obarit tai Canonin SpeedLite 430EX -salama, joita halajan maksavat enemmän…

Onneksi itsehillinnän kehittäminen ja tietynlainen säästeliäisyys ovat eduksi myös valokuvauksessa, joten jarruttelusta on hyötyä muutenkin kuin, etteivät rahat lopu kesken.

Päivitys 15.7.2008 ti 00:36: Hoksasin juuri, että kamerat ovat tuossa kuvassa suurempia kuin luonnossa. Pienempikin siis riittäisi. Lisäksi olisi koon arvioimisen helpottamiseksi pitänyt kuvata mukaan jokin vertailuesine – kuten SD-kortti (se olisi ollut helppo löytää ehjästä kamerasta) – mutta eipä tullut ajoissa mieleen.

Uusi kone tai vanha henkiin… – osa 2

Eilen kertoilin konetilanteestani ja nyt voi ilokseni todeta, että ainakin osa toimenpiteistä vaikuttaisi tehonneen. En ehtinyt vielä kokeilla kaikkea, mutta käynnistys tuntuisi nyt onnistuvan kerralla (ilman vaihtelevaa määrä BSOD-kierroksia).

Suorittamani toimenpiteet olivat:

  1. kaikki USB-laitteet USB2.0-portteihin
  2. USB-ajureiden poistaminen ja uudelleen tunnistaminen laitehallinnassa
  3. uusimman ATI Catalystin asentaminen
  4. BIOS-asetusten tarkistus
  5. Catalystin asetusten säätäminen

Vaiheen 1 ja 2  jälkeen mikään ei vielä muuttunut. Vaiheessa 4 tarkistin kaikki asetukset, mutta oleellisista vga fast-write oli jo disabled, vaihdoin kuitenkin AGP-näytönohjaimen oletukseksi ja lisäksi disabloin quick bootin (ts. kone kelaa muistin läpi ennen kuin aloittaa muut toimet – kahdella gigalla se vie hetken aikaa). Vaiheet 3 ja 4 toivat kuitenkin mukanaan kaksi muutosta: ei BSODia buutissa eikä kolmas näyttö enää suostunut toimimaan (PCI-väylään kytketty ikivanha ATI Rage II -näytönohjain, joka ei ilmeisesti käynnisty ollenkaan, jos AGP on oletuksena). Vaiheen 5 jälkeen koetin vielä muuttaa pari BIOS-asetusta ennen kuin buuttasin Windowsiin asti. Plug’n’Play Aware OS -asetuksen enabloiminen ei kuitenkaan vaikuttanut kolmanteen näyttöön mitään. Catalystin asetuksissa disabloin agp writen molempien näyttöjen osalta.

 Kaiken tämän jälkeen päätin sitten vielä kokeilla olisiko USB:lle tapahtunut jotain – ja olihan sille! Kokeilin ensin tikulla, josta XP ei herjannut, notta se voisi toimia nopeammin USB2.0-portissa. Tästä yllättyneenä kokeilin vielä siirtää kuvia suoraan pokkarikamerastani ja ne siirtyivätkin rivakasti. Näyttäisi siis siltä, että kaksi ongelmaa tuli ratkaistuksi yhden illan aikana, vaikka aikaa ei ollut edes käytettävissä kovin paljon.

Tänään varmaankin irrotan PCI-näytönohjaimen koneesta kokonaan ja siirryn toistaiseksi ”vain” kahden näytön käyttöön. Lisäksi, jos em. korjaukset tuntuvat edelleen olevan kohdallaan, kokeilen varmaan jälleen, jos kolmas giga muistia kelpaisi systeemille. Catalystin kaatuminenhan se ongelma aiemmin oli eli uusimman version ja asetusmuutosten jälkeen toivoa voisi olla. Quick bootin enablointiakin varmaan kokeilen jossain välissä nähdäkseni oliko sillä osansa BSODin katoamisessa vai ei. Kolmen gigan kanssa olisi kuitenkin kivempaa, jos sen läpikäyntiä ei startissa tarvitsisi odotella, mutta toki se on BSODia parempi, jos valita pitää. Jos vielä äänikortin särinäkin kaikkoaisi, niin vanha kone saisi varmasti lisäaikaa vielä melkoisesti. Uuden kyllä ehtii hankkia myöhemminkin, jos vanha vain toimii kunnolla.

Tiivistettynä tilanne eilen illalla: kone käynnistyy kerralla ilman BSODia ja USB2.0 toimii, mutta kolmas näyttö ei. Muiden ongelmien osalta testaus on vielä kesken.

Uusi kone tai vanha henkiin…

Jo useita vuosia olen toistuvasti miettinyt uuden koneen hankkimista. Koneenihan on ollut jonkin verran rikki jo kolmesta viiteen vuotta. Viime vuoden alkupuolelta lähtien vikoja on alkanut olla kertyneenä sen verran paljon, että koneen vaihtaminen oli tarkoitus hoitaa jo viimeistään tänä keväänä. Koska kuitenkin törsäsin uuteen kameraan, lykkäsin koneen päivittämisen (alku)syksyyn.

Eilen kuitenkin keskustelin erään kaverini kanssa koneista ja innostuin tutkailemaan Huuto.netistä, jos joku vaikka kauppaisi samanlaista emolevyä kuin omani (MSI KT3 Ultra-ARU eli MS-6380E, VIA Apollo 266A -piirisarja, AMD Socket A, ATA133 RAID, USB 2.0 [NEC], 6.1 SPDIF koksi ja optinen lähtö). Ihan samaa ei löytynyt, mutta päädyin edelleen FAQ:n kautta käyttäjäfoorumiin, jossa törmäsin kuvauksiin samoista ongelmista, joita minullakin on ollut.

Ensimmäisenä ilmennyt ongelmani on USB2.0:n toimiminen vain USB1.1:n nopeudella (vain yksi esimerkkiketju, sama ongelma tuntuu olevan melko yleinen). Joitakin ratkaisujakin tarjotaan ja aionkin kokeilla niitä. Lainaanpa tähän pari ratkaisuehdotusta:

I solved my problem
When i use my usb 2.0 ports i must have nohting in the usb 1.1 ports
I now put all my usb devices in the usb 2.0 ports
This comes because my chipset has a major bug

Toinen vaihtehto: Poista kaikki USB:hen liittyvät ajurit, boottaa ja anna Windowsin tunnistaa ne uudelleen. Toista, kunnes USB2.0 toimii…

Seuraava ongelma tuli ATI Radeon 9600XT:n kanssa lisämuistien myötä (osat 2 ja 3). Catalyst-ajurit nimittäin kaatuvat, jos muistia on enemmän kuin 2 gigaa. Syy voi tietysti olla esim. muistiavaruuden loppuminen kesken, jos näytönohjaimen 512Mt:n varaus lasketaan yhteen kolmen gigan keskusmuistin kanssa, mutta näin ei mielestäni pitäisi olla. Myös tähän tarjotaan foorumilla joitakin ratkaisuja (lähinnä ajuripeliä) ja niitäkin aion kokeilla. Voi olla, että näytönohjaimella on jotain tekemistä myös koneen buuttausongelman kanssa, joka kyllä on ilmennyt toisinaan jo pitkään ja muistaakseni myös ennen tätä näytönohjainta. Kone siis käynnistyy Windowsin aloitteluun asti, mutta sitten tule BSOD. Ja toisinaan kone myös jumiutuu kesken kaiken ja se on pakko sammuttaa väkisin. USB2.0-ongelman jälkeen tämä on ikävin. Ehkä jopa ikävämpi, sillä USB2.0:aa vaativat massasiirrot esim. kamerasta voin hoitaa läppärillä ja synkata verkkolevyn kautta. Silloin varmuuskopiotkin tulee tehtyä samalla. (Focus on Positive!) Lopuksi vielä eräs ratkaisuehdotus näihin Radeon 9600 ongelmiin:

For those of you having trouble getting your radeon 9600 pro video card working well (lock-ups, serious errors, mouse pointer problems, corrupted craphics), and especially lock-ups with certain games (ie. c&c generals) try the following:

My kt333 based msi kt3 ultra-aru mobo (and maybe others) can now be run at full hardware acceleration and 100% stable perfromance by:
1) download and install latest via chipset driver from via site.
2) download and install latest (soundblaster live!) sound card driver
3) download and install latest catalyst 3.7 driver/control panel/samartgart from ati.
4) disable vga fast-write in bios..
5) go to c:programsati technologyati_control_panel and execute smartgart link
6) enable – pci read/write and agp read.
7) disable – agp write (default in my case was ”on” causing the problem).
8) ”apply”, reboot, then ”ok”.

If you are feeling lucky, just try steps 3 through 8…..

Kolmas ongelma ilmaantui jossain vaiheessa ja on tavallaan vain pikkuseikka, mutta pahimmillaan melkoisen häiritsevä. Äänet nimittäin särisevät ja särkyvät varsinkin leffoja katsellessa. Ongelma ei ole liitännässä, koska sama ilmiö on myös optisessa lähdössä. Syyttäisin siis joko äänikorttia tai ajureita. Tätäkin koetan varmaan ratkoa ajuripäivityksillä tai uusimpien ajurien asentamisella uudelleen.

Jos saisin USB2.0-ongelman ratkaistua, olisi konetta huomattavasti mukavampi käyttää. Jos käynnistymis- ja kaatumisongelmat ratkeaisivat, saisi kone varmsti lisäaikaa ja ääniongelman poistuminen parantaisi fiilistä entisestään. Jos sitten saisin vielä näytönohjaimen hyväksymään kolmannen gigan muistia kenkkuilematta, olisi kone taas melkein kuin uusi. Uuden koneen hankkiminen on toki kivaa, mutta budjetin lisäksi jarruttaisin sitä edelleen mielelläni siksi, että nykyisen koneen käyttiksen ja softat olen viritellyt niin mittojen mukaan, että uudella koneella pääsisin samaan vasta kuukausien (tai vuosien) kuluttua. Enkä saisi kaikkea (etenkään meta)dataakaan siirrettyä tai synkattua uudelle koneelle sellaisenaan. Ainakin kuva-arkiston osalta menettäisin jonkin verran oheisinformaatiota. Jos voisin vain vaihtaa emolevyn ja pitää kaiken muuten ennallaan, en jarruttelisi, mutta yhteensopivuus emojen välillä ei ikävä kyllä ole niin hyvällä tasolla (imageyhteensopivuus…).

Päivitys söi ääkköset

Päivitin äsken pikaisesti WordPressin versiosta 2.1.x versioon 2.2.x. Homma meni muuten hyvin, mutta ääkköset menivät solmuun. Tuttu juttu monesta muustakin yhteydestä, mutta aina yhtä typerää. Annan asia nyt olla hetken aikaa ja korjailen sen, kunhan jaksan ajaa sopivan komennon suoraan kantaan. Käsinhän tuota ei kannata korjailla, vaikka sisältöä onkin toistaiseksi melko vähän…

Muistiongelmia ja MS Visual C++ Runtime Library: Runtime Error

Ostin viime kuun lopulla gigan lisää muistia koneeseeni. Tarkoitus oli kasvattaa muistin määrä 2,5 gigaan. Muistin kuitenkin väärin sen, millaisia kampoja koneessani entuudestaan oli – 1024+512 sijasta 3×512. Päälle päätteeksi tuurini oli vielä sen verran huono, että vanhat CL2,5 -luokitellut muistit aiheuttivat lieviä vakausongelmia uuden CL3-laatuisen muistin kanssa. Päädyin siis väliaikaisesti itse asiassa vähentämään muistia eli jätin koneeseen vain yhden 1024 Mt RAM-moduulin. Tähän en kuitenkaan ollut aikeissa tyytyä kovin pitkään.

Eilen sitten kävin hakemassa kaksi kappaletta gigaisia muisteja, jotka kuitenkin olivat eri valmistajan kuin ensimmäinen. Spekseiltään kyllä identtiset, joten niiden piti toimiman oikein yhdessä aiemman muistin kanssa. Kotona sitten laitoin muistit koneeseen ja starttasin. Muuten näytti hyvältä, mutta kun ei näyttänyt – resoluutio oli tipahtanut 800×600-tilaan eli oletin näytönohjaimen ajurien jotenkin seonneen. Aloinkin sitten tyhmänä tutkia tilannetta tällä oletuksella ja tuhrasin jonkin aikaa, kunnes hoksasin, että kannattaisi eliminoida syiden joukosta muistit.

Sieltähän se syy sitten löytyikin. Pelkällä vanhalla gigaisella muistilla kone starttaisi vallan nätisti ihan oikealla resoluutiolla. Samaten pelkillä uusilla muisteilla kaikkia näytti toimivan vallan mainiosti. Yhdistelmä sotki sitten taas näytönohjaimen pasmat pahemman kerran, mistä onneksi pääsi takaisin ihan vain ottamalla erimerkkisen palikan pois. Jätin siis kaksi uutta gigaista muistia koneeseen toistaiseksi ja tutkin pohdin seuraavaa askelta vielä erikseen.

Asensin tämän sekoilun jälkeen yhden lisäohjelman, jonka asentamisen jälkeen huomasin muutamia ikäviä oireita (lähinnä sen, että resurssienhallinta kaatuu MS Visual C++ Runtime Library: Run Time Erroriin(1, kun yritän mennä jollekin muulle kuin järjestelmän sisältävälle asemalle). Lienee mahdollista, että ne johtuvat kyseisestä ohjelmasta (Yahoo! Desktop Search – X1, tarkemmin varmaankin kyseisen ohjelman ensimmäisestä indeksointikierroksesta, jos se aiheuttaa kenties tarpeettoman ahkeraa levyn käyttöä tai lukitsee jotain väärin tjsp.), mutta jossain vaiheessa aloin miettiä, että jos ne johtuvatkin muisteista, enkä vain huomannut niitä ennen X1:n asentamista. Tätä aion testata, kunhan kerkiän. Tai on mahdollista, että systeri on ehtinyt testata asiaa puolestani, kun ilmeisesti on katsellut kämpässäni leffoja minun puurtaessani virtuaalisen ”sorvin” ääressä. Siitä kuulen sitten tarvittaessa illemmalla. Toivottavasti tietysti kone ei ole kaatuillut kovin monta kertaa. (Viimeksi niin kävi tuon ensimmäisen muistien yhteensopimattomuuden takia kaksi kertaa yhden elokuvan aikana.)

Kaikean kaikkiaan – vaikka muistien hinnat ovatkin laskeneet melkoisen siedettävälle tasolle – kustannuksia kertyi sen verran, että aion palata liikkeeseen (Mikromaja) keskustelemaan, jos saisin vaihdettua joko ensimmäisenä ostamani muistin tai jälkimmäisenä ostamani muistit saman merkkisiin. Lisäksi kannattanee tietysti kysyä, jos heillä on tietoa mahdollisista yhteensopivuusongelmista esim. Sapphiren ATI Radeon 9600 XT:n (tuulettimeton ja siksi hiljainen) GPU:n tai kenties emolevyni (MSI KT3 Ultra-ARU + AMD Athlon XP 2600+ CPU) ja ostamieni muistien (400MHz DDR CL3 1024Mt, ensimmäinen M-Tec aka TwinMOS, jälkimmäiset Buffalo) kesken. Näytönohjainhan (ajurit) muisteista näytti sekoavan, mikä tietysti saattaa olla näennäistä, mutta sekin mahdollisuus täytyy pitää mielessä, kunnes toisin todistetaan. Ei kannata tuomita muisteja ennen aikojaan.

1)Tarkemmin lainattuna virheilmoituksia esiintyi kahta lajia:
Microsoft Visual C++ Runtime Library
Runtime error!
C:\windows\explorer.exe
abnormal program termination

ja
Microsoft Visual C++ Runtime Library
Runtime Error!
Program C:\Windows\explorer.exe
This application has requested the Runtime
to terminate it in an unusual way.
Please contact the applications support
team for more information.

Jos ei ensimmäisen, niin ainakin toisen kerran jälkeen explorerin kaatuminen sitten kaatoi myös Active Desktopin. (Mitäs otin sen käyttöön saadakseni eri taustakuvat kahdelle näytölleni…)

Powered by ScribeFire.